Author Topic: Battery Gone  (Read 1637 times)

0 Members and 1 Guest are viewing this topic.

Offline Tistopher

  • Abarth Novice
  • **
  • Posts: 88
  • Thanks: 0
  • Keep going.
    • View Profile
Battery Gone
« on: February 23, 2016, 03:52:47 PM »
Just thought I'd share for people in the future.

Today my APE battery finally died, it did not start yesterday, stop/start hasn't worked for year and a half. Went to start it today and it greeted me with "Excess radiator temperature"

If you generally see this message or other weird messages your battery may be on it's last legs. Mine has struggled to start for the last 2 months, but I'm cheap and wanted to keep it going haha!

Thanks,
Chris
If you spot me my reg is .T15 TYY.

Offline AustinR

  • Barely Abarth
  • *
  • Posts: 34
  • Thanks: 0
    • View Profile
Re: Battery Gone
« Reply #1 on: February 24, 2016, 10:07:08 PM »
Mine is on borrowed time. The car is now over 5 years old and still on the original battery. I wanted to change it last year when it was in for a service, but Platts said it was still OK so leave it alone. That's fine as long as I get some kind of warning that it's failing so that I can get it replaced easily in my home area, and not when I'm on holiday in deepest Pembrokeshire ! Still, I have RAC breakdown cover, so I don't really need to worry, do I?
They replaced the battery on my previous GP Abarth in my driveway, and they've got all the electronic kit to clear any faults in the system and get your Abarth up and running properly again.

Offline will-w

  • 695 Member
  • *****
  • Posts: 679
  • Thanks: 25
  • 'Captain Slow'
    • View Profile
Re: Battery Gone
« Reply #2 on: February 25, 2016, 06:51:31 AM »
Random error messages are completely normal for a Punto with a weak battery; anything from Power Steering to Oil pressure, to Start Stop warnings..

You'd think they'd just program a "Battery Voltage Low" warning but there you go!!
Abarth Punto Supersport
Grigio Campovolo, Skydome, Assetto Koni, Floating brakes
Summer: Gunmetal 18" Esseesse with Bridgestone Potenza RE050A
Winter: Official Abarth Winter Kit (17" with Pirelli Sottozero 210)

Offline Tistopher

  • Abarth Novice
  • **
  • Posts: 88
  • Thanks: 0
  • Keep going.
    • View Profile
Re: Battery Gone
« Reply #3 on: February 26, 2016, 09:32:39 AM »
You think it would be that simple Will!

And Austin, when mine completely didn't crank the engine over no more, I charged it and it gave me that error. So if it dies completely good look trying to get it going again is all I can say. I just went out bought another battery put it in the car and it started first time, after the engine warmed up it even used stop start.

Thanks,
Chris
If you spot me my reg is .T15 TYY.

Offline AustinR

  • Barely Abarth
  • *
  • Posts: 34
  • Thanks: 0
    • View Profile
Re: Battery Gone
« Reply #4 on: March 11, 2016, 09:41:12 PM »
Don't think I've got a battery charger anymore.........