Author Topic: Turbo Display does not show up anymore!  (Read 806 times)

0 Members and 1 Guest are viewing this topic.

AntR

  • Guest
Turbo Display does not show up anymore!
« on: January 14, 2016, 11:24:02 PM »
Hello!

I have a 11 plate Abarth Punto Evo and since I took it for the 30000 km service the turbo display (with the bars) on the speedometer does not show up and instead Im gifted with a small clock. The Abarth logo still shows up on the start of the car so I assume it is the correct software (I think). I was not informed of a update by the dealer (official) so I really dont know why this has happened.

Any help?

Offline dixy

  • Abarth Enthusiast
  • ***
  • Posts: 111
  • Thanks: 2
    • View Profile
Re: Turbo Display does not show up anymore!
« Reply #1 on: January 15, 2016, 11:55:24 AM »
Hi not sure if you have tried this but you can toggle through screens by pressing in the button on the wiper side of the stalk ? Or if you have the radio now set up as the first page from the buttons beside your right leg.
RED APE/SKYDOME/BLACK DECALS/TMC UPGRADES/TITANIUM EXHAUST/ITG PANEL FILTER/

Offline Brian1612

  • 695 Member
  • *****
  • Posts: 1773
  • Thanks: 50
  • 200 bhp Competizione
    • View Profile
Re: Turbo Display does not show up anymore!
« Reply #2 on: January 15, 2016, 06:21:01 PM »
This^^^
---Abarth 595 Competizione Owner---
-Grey Leather Sabelts
-Interscope
-Yellow Brembos
-Engine Remap
-H&R Springs
-12mm & 16mm Spacers
-Mtech Short Shifter
-LED rear lamps
-CF Front Splitter
-CF Dipped Dash
-Yellow Exterior Details (Scuderia Stripes/Scorpions)
-Aluminium Speaker Covers & Plaque