Author Topic: Series 4 Infotainment screen 'blank' issues  (Read 626 times)

0 Members and 1 Guest are viewing this topic.

Offline jenniferlouise

  • 695 Member
  • *****
  • Posts: 553
  • Thanks: 25
    • View Profile
Series 4 Infotainment screen 'blank' issues
« on: September 09, 2017, 04:21:26 PM »
Hi all, just wanted to share some detail on a potential 'malfunction' that is actually not. Ok, so I'm making no sense... let me explain. The other day I went out to the car, unlocked it, hopped in, fired it up and on came the music... just nothing on the 7" screen.  Mild panic. Turn off. Restart the car. Same thing. Go to shops cursing quality control. On return to the car, fire it up and hey, the screen display is back!! Note to self to get it checked out by dealer. Just before booking anything posted a Q on the FB site to see if anyone else has experienced this on a new car. Turns out it's a safety feature. The screen blanks out when the cabin temperature becomes too high and comes back when it's cold down. Clever little car.

You'll all be laughing at me. You probably knew this. It's even written in the handbook (like anyone reads these!) however someone may not have known this and sometime in the future this little post will save someone a wasted trip to Abarth.
Abarth history : 2014 595C Turismo Scorpione Black I 2016 595C Turismo Podium Blue I 2017 695C Yamaha XSR Circuit Grey #035 🦂 & Yamaha Tricity MW125 scooter 😎

Offline noddyrocket

  • Abarth Novice
  • **
  • Posts: 83
  • Thanks: 2
    • View Profile
Re: Series 4 Infotainment screen 'blank' issues
« Reply #1 on: September 09, 2017, 05:07:37 PM »
Thats a top tip! I think mine has done it once (when we had a summer day waaaayyy back!)

Rory the red 595 Trofeo.  My 3rd Abarth, I must be addicted :)

Offline Montybaber

  • Barely Abarth
  • *
  • Posts: 29
  • Thanks: 1
    • View Profile
Re: Series 4 Infotainment screen 'blank' issues
« Reply #2 on: September 09, 2017, 08:15:08 PM »
Mine did this last Saturday on my XSR, was really worried and googled it and it advised locking and leaving five mins to reset and bobs yr uncle! it wasnt particularly hot do will be keeping an eye on it

Offline Andy595

  • Abarth Professional
  • ****
  • Posts: 278
  • Thanks: 11
    • View Profile
Re: Series 4 Infotainment screen 'blank' issues
« Reply #3 on: September 10, 2017, 08:54:55 AM »
We have had this issue once, in the heat of a long summer in the UK😎Not sure why it would happen in a damp September though.
Does this mean you cannot use Satnav when the weather is too good?
On a different note, how do you clean finger grease marks off the screen?
Has anybody found a good use for UConnect?
Andy

Offline Steve zxr

  • Barely Abarth
  • *
  • Posts: 12
  • Thanks: 2
    • View Profile
Re: Series 4 Infotainment screen 'blank' issues
« Reply #4 on: September 10, 2017, 11:52:39 AM »
   

  Thanks for the info Jennifer  8)

Offline StevieJ

  • Abarth Novice
  • **
  • Posts: 86
  • Thanks: 6
  • Instagram @steviej_abarth
    • View Profile
    • Abarth Owners Club South East
  • Registration Number: SJ07 JAY
Re: Series 4 Infotainment screen 'blank' issues
« Reply #5 on: September 10, 2017, 03:29:24 PM »
Have to say that I've not had any problems with mine even when it's been parked in the sun on hot days.
Series 4 Comp - 206bhp & 276ftlb, BMC OTA , Forge BOV & intake, Power Motive exhaust, Bilstein B14's, 12&16mm spacers, DNA rear brace, camber plates, lateral tie rods, MTech, Mishimoto can, Defi boost gauge, wearelikewise shifter, GTT batt cover, red speaker grills, matt black roof & spoiler wrap

Offline pederb6

  • Barely Abarth
  • *
  • Posts: 49
  • Thanks: 5
    • View Profile
  • Registration Number: B-KG 4578
Re: Series 4 Infotainment screen 'blank' issues
« Reply #6 on: September 11, 2017, 12:09:01 PM »
Well, we had one of the coldest and wettest summer in Berlin with temps seldom reach over 20+ so that is not the issue
-Peder Beckman-
2017 695 Abarth XSR
Eibach Red Springs
Standard 1.4 T-Jet - Garrett Turbo GT1446
Akrapovic Exhaust

KIT ELABORAZIONE 180HP
BMC Airfilter
Koni FSD Shocks all around
Front M4x38mm red Brembo brake calipers
Front floating drilled and ventilated 305x28mm Brembo discs
FERODO HP1000/1 high

Offline Andy595

  • Abarth Professional
  • ****
  • Posts: 278
  • Thanks: 11
    • View Profile
Re: Series 4 Infotainment screen 'blank' issues
« Reply #7 on: September 11, 2017, 03:31:00 PM »
Well, we had one of the coldest and wettest summer in Berlin with temps seldom reach over 20+ so that is not the issue
Somehow I am glad to hear that following Brexit we have infected you with our standard summer😎
Andy

Offline SusieSue

  • Barely Abarth
  • *
  • Posts: 24
  • Thanks: 2
    • View Profile
Re: Series 4 Infotainment screen 'blank' issues
« Reply #8 on: September 11, 2017, 03:32:04 PM »
Thanks for the heads-up on this, would definitely have worried me.

Offline Squadrone Rosso

  • Barely Abarth
  • *
  • Posts: 25
  • Thanks: 0
    • View Profile
  • Registration Number: GK02 AYW
Re: Series 4 Infotainment screen 'blank' issues
« Reply #9 on: September 17, 2017, 01:16:28 PM »
Mine did this today (7" Nav version).  Music but black screen.  Turning of & on made no difference.

Left the car for 40 mins, came back, all good.

Bizarre!
Cheers,

Simon :)

Offline Fish

  • 695 Member
  • *****
  • Posts: 639
  • Thanks: 28
  • 595 Comp
    • View Profile
Re: Series 4 Infotainment screen 'blank' issues
« Reply #10 on: September 17, 2017, 03:52:20 PM »
Had this happen once, I found the only way to resolve it was to lock then unlock the car. Worked ok after that.

Fish

Offline RickC

  • Barely Abarth
  • *
  • Posts: 1
  • Thanks: 0
    • View Profile
  • Registration Number: RC04 PFC
Re: Series 4 Infotainment screen 'blank' issues
« Reply #11 on: September 18, 2017, 06:01:08 PM »
This has happened to mine after a software upgrade. Contacted Rockingham Cars and they've had a few issues with blank screens,sothey're going to replace the unit.

Offline Fish

  • 695 Member
  • *****
  • Posts: 639
  • Thanks: 28
  • 595 Comp
    • View Profile
Re: Series 4 Infotainment screen 'blank' issues
« Reply #12 on: September 20, 2017, 10:35:27 AM »
I've just dropped my car at the local dealers for a service and mentioned the update. The service manager said that the update does not appear to fix the issue as per one of their technicians cars with the issue.

Fish

Offline pederb6

  • Barely Abarth
  • *
  • Posts: 49
  • Thanks: 5
    • View Profile
  • Registration Number: B-KG 4578
Re: Series 4 Infotainment screen 'blank' issues
« Reply #13 on: September 20, 2017, 01:36:37 PM »
Yea, they want to run a update on mine also, but I think it is a faulty temperature sensor in the screen.
-Peder Beckman-
2017 695 Abarth XSR
Eibach Red Springs
Standard 1.4 T-Jet - Garrett Turbo GT1446
Akrapovic Exhaust

KIT ELABORAZIONE 180HP
BMC Airfilter
Koni FSD Shocks all around
Front M4x38mm red Brembo brake calipers
Front floating drilled and ventilated 305x28mm Brembo discs
FERODO HP1000/1 high

Offline benjamin_t_monkey

  • Barely Abarth
  • *
  • Posts: 40
  • Thanks: 2
  • 189 of 695 Abarth 695 XSR
    • View Profile
Re: Series 4 Infotainment screen 'blank' issues
« Reply #14 on: October 03, 2017, 09:57:40 AM »
Had this happen to me on my XSR, it wasn't that hot or warm so my guess is that if this is the case then the sensor or the code isn't doing what it should.
189 of 695 Abarth 695 XSR

  - Garrett Turbo
  - Eibach springs
  - Akrapovic  exhaust
  - BMC filter
  - Kit Elaborazione
    - 180bhp
    - Koni damping
    - Brembo front calipers, drilled front and rear discs