Author Topic: 500C with a MTA gearbox issue  (Read 201 times)

0 Members and 1 Guest are viewing this topic.

Offline d3m0n

  • Barely Abarth
  • *
  • Posts: 27
  • Thanks: 0
    • View Profile
500C with a MTA gearbox issue
« on: July 23, 2018, 02:31:23 PM »
For the past 2-3 weeks its occassionally playing up from a start with it not going into gear or feeling like it is slipping badly, this weekend however we lost reverse and it wouldnt go higher than 2nd. The wife limped it home and took my car (Golf). I tried the usual ignition off and on to see if it would come back to life and nothing aside from a flashing N and a refusal to go into R. I left it until last night and tried again and it worked like it should. Obviously no warning lights etc etc so not sure what is happening (or why)

Is this the start of the box going bang or is it something stupid like fluid or a connection. Does anyone have experience of this as we had a similar issue on her old fiesta but that stuck in 5th on the M27 (that was really bad) and that needed the gear actuator resetting and the whole system rebleeding.......aside from the time needed to strip it and send the bit off it was a fairly painless job.

#answersonapostcard

Offline 137699

  • Abarth Enthusiast
  • ***
  • Posts: 135
  • Thanks: 7
    • View Profile
Re: 500C with a MTA gearbox issue
« Reply #1 on: July 24, 2018, 09:12:59 AM »
We had the same on ours - it was the clutch actuator needed replacing - quite a common issue according to the local specialist we spoke to but we had it done at a dealer as it was still under warranty.
All sorted since.

Offline d3m0n

  • Barely Abarth
  • *
  • Posts: 27
  • Thanks: 0
    • View Profile
Re: 500C with a MTA gearbox issue
« Reply #2 on: August 12, 2018, 10:38:03 AM »
Things have moved on I've had it to the garage they ran diagnostics etc and everything aside from 3rd and 4th is working, could be a gear selector in the box as the selespeed unit is testing ok (according to his computer), so looks like a full strip and rebuild or a new gearbox ......both are gonna mean a bill well in excess of 1k :(

Offline 137699

  • Abarth Enthusiast
  • ***
  • Posts: 135
  • Thanks: 7
    • View Profile
Re: 500C with a MTA gearbox issue
« Reply #3 on: August 13, 2018, 09:17:39 AM »
What diagnostics were used?

I'd be 100% shocked it if it was anything other than clutch actuator.