Author Topic: possible canbus ? tho not convinced  (Read 52 times)

0 Members and 1 Guest are viewing this topic.

Offline ineedabarth

  • Barely Abarth
  • *
  • Posts: 2
  • Thanks: 0
    • View Profile
possible canbus ? tho not convinced
« on: December 07, 2018, 11:17:36 AM »
Hi all

Up until a few weeks ago i was toddling around the area happily in my abarth 2012 model.

I woke up in the morning went to start it , . . .  . . . flat.

ok no problem i know the battery is new maybe i left a light on so i charged the battery and all was good.

the next day i went out side to use the car again and it was flat so i get a new battery and put this on , all good for a few days and flat again but now ive noticed a couple of other factors.
its clear now that the car is draining the battery as the alternator has also been tested and appears to be working perfectly.

if i take the battery terminals off of the car and leave it for a few days the battery will hold charge.

the mileage is flashing and my left head light isnt working (nor is my blue and me ).

before i go to fiat and get a mortgage out to remedy this i wanted to know if anybody has had this issue?

not that it makes any difference but i would like to point out since the cars life started the work that has been caried out.

regular servicing , brakes pads tyres blablabla
timing belt which i had done a few months ago.
clutch and flywheel.
new bulbs here and there.

can anyone help a newb please , all comments are appreciated .


Offline Neil R

  • 695 Member
  • *****
  • Posts: 646
  • Thanks: 24
    • View Profile
Re: possible canbus ? tho not convinced
« Reply #1 on: December 07, 2018, 01:03:30 PM »
Hi Chris, welcome to the AOC.  It might be worth posting this question on the Abarth facebook pages, lots of help to be found there,
Don`t forget to post a picture or two of your car on here.
Neil.
Abarth 695 XSR Yamaha Limited Edition. Kit Elaborazione.
Carbon Gear stick, Carbon Sill Plates .Smoked Wind Deflectors.