Author Topic: Weir metalic sound when car is moving cold! Abarth 595 comprtizione  (Read 348 times)

0 Members and 1 Guest are viewing this topic.

Offline Abarth35959

  • Barely Abarth
  • *
  • Posts: 1
  • Thanks: 0
    • View Profile
Hello everyone,

I recently purchased an Abarth 595 competizione,

With only 2000 km, my car is making some sort of a weird nose.

The following occurs only when the car is COMPLETELY COLD, and disappear the second itís hot which bugs me even more.

When I turn on the car, and move in COLD START, if I make a full turn to the left or to the right and I slowly move, there is this weird sounds of friction, a friction of metal, like something is wrong with the steering. It is almost like I am dragging something.

however, few meters later the sound disappears and everything seems to work perfectly fine.

I really could not figure out where the probleme was coming from and the gravity of it

thank you in advance for all your replies,

cheers

Offline Andy595

  • Abarth Professional
  • ****
  • Posts: 429
  • Thanks: 18
    • View Profile
Re: Weir metalic sound when car is moving cold! Abarth 595 comprtizione
« Reply #1 on: April 12, 2020, 02:46:10 PM »
Hi

Am not a mechanic so don't rely on my guesswork!

I had a car some years back with a similar sound, turned out to be a brake wear indicator strip, like a spring clip within the brake pad, when wearing down , it pops out and rubs on the disc.

Don't know why this would be an issue only when cold though.

Andy